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Using wRASP 
(A Short Primer) 

 
 
Overview 
wRASP (Rocket Altitude Simulation Program for Windows) is a PC program that 
simulates the flight of a model rocket in one dimension. The following paragraphs 
should help you become familiar with its operation. 
 
Installation 
The latest version of wRASP is available on the NAR Education CD, a diskette, 
or the wRASP web site: 
 
http://www.wrasp.com 
 
If you downloaded the wrasp95m.zip file, use Winzip or a similar program to 
unzip the files into a temporary directory (like C:\temp). If you downloaded the 
wrasp95m.exe file, move it to a temporary directory and run it. Once the files are 
extracted in either case, run the setup.exe program in the temporary directory. 
 
If you have a diskette, locate and run setup.exe on the A:\ drive. 
 
Running setup.exe will launch the familiar InstallShield®Wizard which will install 
the wRASP program. If no changes are made, the following installations will 
occur: 
 
> wRASP files will be installed in C:\Program Files\C & S Software\wRASP 
> two files (BC520rtt.dll and Bwcc.dll) will be placed in C:\windows\system 
> a wRASP folder will be added to Start\Programs 
> uninstall information will be added and is available from the control panel 
 
Uninstalling wRASP 
If you installed wRASP using InstallShield®, select Start/Settings/Control Panel 
and then select the “Add/Remove Programs” icon. Now select wRASP from the 
list of programs and then the “Add/Remove” button. You may elect to keep the 
Borland DLL files since other programs might use them. 
 
If you had run wRASP, some output and log files were generated and must be 
deleted manually after Uninstall runs. Using Windows Explorer, delete the 
“C:\Program Files\C & S Software” directory or whatever directory was used to 
install wRASP. 
 
Finally, manually delete the wRASP configuration file, “wrasp.ini” in the 
C:\WINDOWS directory. 

http://www.wrasp.com/
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Running wRASP 
wRASP uses the familiar Windows Graphical User Interface (GUI) that includes 
menus and mouse operations. However, someone new to rocketry may not know 
how to use it. This section should make wRASP operation “old hat”. 
 
Start the program by clicking on “Start” at the bottom of the Windows screen. 
Next, click on “Programs”. Locate the “wRASP” folder and then on the wRASP 
icon. The program should then load and be ready for use. 
 
When first loaded, wRASP contains enough data to launch a rocket. The data is 
from an Estes Alpha model rocket kit and uses an Estes A8 rocket motor. The 
launch conditions (environment) are for that elusive “standard” day at sea level. 
(how to change all these things will be covered in the following sections). 
 
Without changing anything, click on the “Launch” menu item near the top left of 
the screen. Another way is to hold the “Alt” key and press the “L” key (shown by 
the L in the menu). This action launches the rocket described in the data. The 
data items will change and two graph lines will appear. Then everything will stop. 
 
Here is what the different sections mean: 
 
The data box in the upper left contains the basic rocket information. The kit 
manufacturer supplies the body tube diameter and typical empty weight. The 
motor manufacturer supplies the motor weight and its thrust data curve (shown in 
the lower right corner). The coefficient of drag, CD, is the wRASP initial guess 
and is the most likely candidate to change. This value describes how 
“aerodynamic” the rocket is. 
 
The environmental conditions appear in the box in the lower center of the screen. 
This data can be changed to match your location and climate. Sometimes this 
can drastically affect how the rocket flies. 
 
The box in the center of the screen shows the conditions at the end of the flight. 
The difference between the rocket weight here and the data in the upper left 
corner shows how much propellant was burned during the flight. (Press “Launch” 
again to watch this number change). 
 
The box in the lower left shows flight parameter maximums during the flight. 
These help determine whether a flight will be a safe flight or not. Problems occur 
if a very high acceleration is indicated or very high speed (near the speed of 
sound or Mach 1). The altitude may also be too low, causing the ejection charge 
to not function. Also, the rocket velocity at the top of the launch rod may be too 
low, causing the rocket to not fly straight up and/or become unstable. 
 
The graphs in the upper right box help explain what happened during the flight. 
The red/black curve is the rocket altitude and the blue curve is the rocket velocity 
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(absolute value – positive going up and negative going down). The red section of 
the altitude curve indicates that the motor is burning and providing thrust. 
 
There are several vertical lines that point out events that occur: 
 
bo – motor burnout – this is where the motor propellant has all been burned up. 
Notice that the velocity drops off after this event as gravity and drag force 
become the only forces acting on the rocket. 
 
apo – apogee – the point of maximum altitude and also the point where the 
velocity is zero and is in the process of going positive to negative. 
 
d0,d3,d5 – ejection delay times – these are the points in the flight where the 
ejection charges occur. The table in the center of the right side of the screen 
displays the rocket velocities at these times. This can be used to pick the best 
available ejection charge for the flight – the one closest to apogee and closest to 
zero velocity. Note – for this motor, the d0 (zero delay) is no longer available and 
was typically used as a booster motor. The d5 motor has also been recently 
discontinued, though some are still available. 
 
So, after launching an Estes Alpha with an Estes A8 motor on the coast on a 
“perfect” day, we can determine that the rocket will go approximately 256 feet up, 
reaching a speed of 137 feet per second, and that an ejection delay of 3 seconds 
is probably the best to use (although 5 seconds would probably work and eject 
closer to the ground – for a shorter walk). We can also see that the motor will 
burn for almost half a second and that the rocket will be moving the fastest right 
before the motor burns out. 
 
As a caveat, the actual motor and rocket combination can have flights that vary 
from this due to construction and individual motor performance. Actual flights can 
be used to get a better estimate of the CD value and therefore produce more 
accurate simulations. 
 
Use the mouse and click on the curve at the point of apogee. The altitude value 
on the left side of the curve box, the velocity value on the right side, and the time 
at the bottom will all change to reflect the conditions at that point of the flight. 
 
Click on the curve at the “d3” delay point – this should be about 3.5 seconds into 
the flight at an altitude of 151 feet and a velocity of 17 feet/second. 
 
If you are a science teacher, you may want to look at all these data values in 
their metric equivalents. To do that, select the “Options” and then “Units and 
Stuff”. Now click on the units desired for the different measures. Interestingly, 
rocketeers use the metric “newtons” to measure thrust while using English units 
for everything else. 
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Selections of units and other options will be remembered and used the next time 
wRASP is run, thus saving setup time. 
 
wRASP has many more options and some, but not all, will be described in the 
next two sections. For more detailed information, select the “Help” menu item 
and then “Running wRASP”. 
 
 
Typical Use 
Of course, the location, rocket kit and motor will be different. Let’s assume that 
we have just purchased a Pratt Hobbies Super 6 model rocket from the Internet 
and have a Quest B6-4 motor. We will fly somewhere near Windom, Texas (900 
feet mean-sea-level – MSL) on a balmy 85°F day. Here is how it is done: 
 
First, set the environment: Select the “Data” menu item and then “Environment”. 
Enter 900 into the base altitude data box. Click on “ICAO” standard day and then 
enter 85 degrees into the temperature box. Click “recalculate” and notice that the 
density and speed-of-sound constants change. Also notice that the atmosphere 
model was automatically changed to “Hot Day”. The pressure will be left the 
same, although it could be changed as well. 
 
Next, load the rocket kit data: Select the “File” menu item and then :”Browse 
Rocket Database”. A dialog box will appear. Scroll down the list of manufacturers 
in the box on the left until “PH Pratt Hobbies” is found – click on that line to select 
it. The kit box on the right will reposition to the first Pratt kit – scroll down and find 
and select the “Super 6”. Notice that information about the kit will appear. Select 
“Load Data” and all this information will be loaded to the main screen. 
 
Oops, if you looked at the list of recommended motors for the Super 6, it only 
lists A-power motors and we are planning to use a B6-4. Better build the kit as 
strong as possible. (The kit flies on B and C motors nicely, though). This list is 
just a guide, and may be incomplete. 
 
Let’s assume we will fly the rocket kit unpainted and that a higher CD probably 
ought to be used, say 0.7. Change it by selecting the “Data” menu and then 
“Rocket”. Change the CD value to 0.7 (it should already be highlighted). None of 
the other items will change but note that it is here that a multi-stage rocket’s data 
is entered. When ready, select “OK”. 
 
Finally, change the motor from the A8 used previously: Select “Data” and “Stage 
1” – another dialog box will appear. There are lots of motors to choose from – 
they are listed by the “power” letter. The Estes A8 should already be selected. 
Scroll down and select the Quest B6 (B6 QU). The data will change. Notice that 
“Maximum Body Diameter” is listed. This is to clue you when a motor is larger 
that the diameter of the rocket data already loaded. wRASP generates a warning 
but allows you to simulate the flight anyway (a “fantasy” flight).  
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Now click “Show Data” – a small box with the thrust curve for the motor will 
appear. If this is not what you want, you can close the data box and try 
something else. We want the Quest B6-4, so just select “OK”. 
 
All of the data should now be visible on the main wRASP screen. Look it over 
and select “Launch” when you are ready. The curves will appear and it looks like 
the rocket will go to almost 960 feet in 6.3 seconds. Since the 4 second delay will 
eject prior to apogee, it probably will not get that high. Clicking on the d4 point 
shows 917 feet – quite a bit higher than the Alpha on an A8! 
 
You can now easily try other motors by selecting them using the “Data/Stage 1” 
menu items and then selecting “Launch”.  
 
 
Advanced Use 
The wRASP program includes a database of rocket kits and motors. However, 
the data needed to represent a rocket kit is usually available in the catalog or on 
the kit packaging material. The following data is needed to calculate a basic 
predicted altitude: 
 
 Rocket empty weight, in ounces 
 Maximum diameter of the body tube, in inches 
 An initial guesstimate of the coefficient of drag, like 0.7 
 Motor type 
 
This data is entered using the “Data” menu – “Rocket”, “Stage 1/2/3”, and 
“Environment”. Once the proper data is entered, the “configuration” can be saved 
for future use. Use the “File” menu to save and load these rocket configurations 
by a name that you will easily recognize. One advantage to this method is that all 
of the data is saved, including the CD and motor selections. Saved configuration 
files have a “.rsp” suffix. Since wRASP associates this suffix to itself when it is 
installed, double clicking on a saved configuration file will run wRASP and load 
the file, ready to launch. 
 
Several kit configuration files are saved as examples. Using the “File” and “Load 
Rocket Config”, load the Estes Comanche 3 file. Notice that the 3-stage rocket 
has three different CD values, along with different motors for each stage. Launch 
the rocket for an example of a multi-stage flight – this configuration is the one 
Estes specifies for maximum altitude. 
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Troubleshooting wRASP 
wRASP has been installed on Windows 3.1, 95, 98, and NT. It has not been 
installed on Windows 2000, Me, or XP. However, it is expected to work on these 
versions as well. 
 
The most common problem is an older version of the BWcc.dll file in the 
C:\WINDOWS directory which overrides the one in the C:\WINDOWS\SYSTEM 
directory that wRASP installs. Just delete the file in the C:\WINDOWS directory. 
This problem is evident when wRASP will run (and launch) but no data items can 
be changed. The “Help” menu also has additional troubleshooting information. 
 
 
Additional Help 
The wRASP “Help” menu is the best location for additional information on the 
workings of wRASP. 
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